Upgrade

This topic shows you how to upgrade Digital.ai Deploy from one version to another. To upgrade the version you only need to update the “ImageTag” parameter to the desired version in the values.yaml file. To view the list of available ImageTag parameters for Digital.ai Deploy, see the following link Deploy_tags

Upgrade Strategies

Kubernetes offers two valid update strategies for statefulSets, the RollingUpdate strategy and the OnDelete strategy. We use the Kubernetes native rolling update strategy to upgrade the application. The RollingUpdate strategy is the default strategy for StatefulSets. The RollingUpdate strategy will update all Pods in a StatefulSet, in a reverse ordinal order. See the official Kubernetes documentfor more details.

Steps to upgrade Digital.ai Deploy chart are as follows:
  • Before upgrading the chart make sure to export all the passwords so that after upgrading, the password remains same.

To export the password, execute the following command

helm status xld-production

and export Postgresql password, Rabbitmq password and Digital.ai Deploy password as shown below:

export POSTGRESQL_PASSWORD=$(kubectl get secret --namespace default xld-production-postgresql -o jsonpath="{.data.postgresql-password}" | base64 –decode)

export RABBITMQ_PASSWORD=$(kubectl get secret xld-production-rabbitmq-ha -o jsonpath="{.data.rabbitmq-password}" | base64 --decode; echo)

export ADMIN_PASSWORD=$( kubectl get secret --namespace default xld-production-xl-deploy-helmcharts -o jsonpath="{.data.deploy-password}" | base64 --decode; echo)
  • Move to your Digital.ai Deploy chart folder and open the values.yaml file for editing
  • Update the ImageTag parameter to the desired version that you want to upgrade and save the file. For example, upgrading the Digital.ai Deploy from 9.7.0 to 9.8.0
  • Once the required changes are done, run the helm upgrade command:

helm upgrade xld-production <deploy-chart-name>

  • Once the upgrade completes successfully, you can access the application UI with the ingress loadbalancer.

Note: Currently upgrading custom plugins and database drivers is not supported. In order to upgrade custom plugins and database drivers, you will need to build a custom docker image of Digital.ai Deploy containing the required files.

See the adding custom plugins section in the Xebialabs official documentation for more information.

Next Step