How XL Deploy checks application dependencies

When you deploy, update, or undeploy an application, XL Deploy performs a dependency check, which may detect the following issues:

Note: For more information on dependency checks, see Application dependencies in XL Deploy.

Message Possible cause Example
Error while trying to resolve the dependencies of application <name>. Cannot find an application with the name <name>. While deploying or updating an application, another application that it depends on is not present in the environment. The application requires application AppA version [1.0.0, 2.0.0), but AppA is not present.
Error while trying to resolve the dependencies of application <name>. Cannot find matching version of application <name> for version range <range>. While deploying or updating an application, a version of the application(s) it depends on is present in the environment, but the version is too old or too new. The application requires application AppA version [1.0.0, 2.0.0), but version 2.1.0 is present.
While deploying or updating an application, XL Deploy looks for an application in a certain range, but the version that is present is not in major.minor.patch format. Application AppAndroid version [2.0.0, 5.0.0] is required, but version KitKat is present.
While updating an application, an application that is present in the environment depends on that application, but the version that you want to update to is not in major.minor.patch format. You want to update application AppAndroid to version KitKat, but the installed application AppC requires AppAndroid to be in range [2.0.0, 5.0.0].
Application <name> cannot be upgraded, because the deployed application <name> depends on its current version. The required version range is <range>. While updating an application, an application that is present in the environment depends on that application, but the version that you want to update to is out of the dependency range of that application. You want to update application AppA to version 2.1.0, but the environment contains a version of application AppC that depends on AppA range [1.0.0, 2.0.0).
Application <name> cannot be undeployed, because the deployed application <name> depends on its current version. The required version range is <range>. While undeploying, an installed application depends on the application that you want to undeploy. You want to undeploy application AppA 1.5.0, but the environment contains a version of application AppC that depends on AppA range [1.0.0, 2.0.0).

XL Deploy uses the Dependency Resolution property, of the deployment package that you choose, when setting up the deployment to select the other application versions. For more information, see How does XL Deploy select the versions to deploy.